AWS has been restored and all affected services are operational again.
Posted Oct 21, 2025 - 13:16 EDT
Identified
Amazon Web Services is experiencing a major outage which is impacting several services and vendors. Insurance verification features are impacted. Amazon is working on to resolve the outage as quickly as possible. Med-Metrix is actively monitoring the outage and will share updates as they are provided to us by AWS Support. Thank you for your patience and understanding.
Posted Oct 20, 2025 - 13:02 EDT
This incident affected: API (Database) and Integrations (Insurance Eligibility API).