Change Healthcare Eligibility Service
Incident Report for Med-Metrix
Resolved
Change Healthcare is now responding normally.
Posted Jun 24, 2021 - 15:00 EDT
Monitoring
Change Healthcare's real-time eligibility APIs are responding healthy again. We'll continue to monitor the eligibility results from Change.
Posted Jun 24, 2021 - 14:25 EDT
Identified
Change Healthcare's real-time eligibility APIs are currently down. Pulling eligibility using a payer from Change will not respond at this time. We're working with Change Healthcare to get a timeline for when they'll return to normal operation.
Posted Jun 24, 2021 - 14:08 EDT
This incident affected: Applications (Clinician Console).