Dashboard Loading
Incident Report for Med-Metrix
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 15:20 EDT
Identified
We have identified the issue and working to resolve the issue for all affected users.
Posted Mar 15, 2024 - 14:39 EDT
Investigating
Dashboard is failing to load for some users. We are investigating this issue.
Posted Mar 15, 2024 - 14:14 EDT
This incident affected: Applications (Clinician Console).